GSAK 201

“My GSAK”
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This is a step-by-step guide to teach you about customizing GSAK.  Underlined text in this guide is a link to a web site – click on the underlined text to go directly to that website.   

This guide builds on GSAK 101 and assumes that you’re familiar with the topics covered there.   GSAK 101 covers:

· Geocaching.com Premium Membership

· Downloading GSAK

· Installing GSAK

· Starting GSAK

· Load Cache Data

· Creating Your Home Location

· Getting and Loading Pocket Queries

· Viewing Cache Information & Split Screen Views

· Sorting

· Selecting Caches & User Flags

· Filtering

· Sending Waypoints to Your GPSr

· Exporting

GSAK 201 (this guide) focuses on how to customize GSAK to create a program that reflects the way you use GSAK and your personal preferences!  It’s designed to be read from start to finish (although not necessarily in one sitting!), and each section builds on the last   
Many GSAK features are not addressed in these guides – for information on those features, please see the GSAK help file (in GSAK, go to the “Help” menu, then click on “Contents”, or press the F1 key on your computer).

Changing the GSAK View

You can customize many elements of the GSAK view to suit your needs or your personal preferences.  This section discusses available customizations.

Rearranging Columns in the Grid View:

You can rearrange the columns in the grid view to show in any order that you wish.  To move a column, simply “drag and drop” the column heading.  Let’s say that you want to have the “Last Found” column next to the “Last Log” column.   Left click on the “Last Found” column, hold down the mouse button, and “drag” the column heading to the left until it’s next to the “Last Log” column.  Release the mouse button and GSAK will move the “Last Found” column to the location where you dropped the heading (next to the “Last Log” column).

Adding or Removing Columns:

GSAK has more data “fields”, which appear in the Grid View as columns, than will fit in one screen.   You can add (or remove) columns in the Grid View so that the columns you use are always showing.  For a description of each column, go to Help>Contents>GSAK Main Menu>View>Add/Delete Columns and click on the list of columns, or click here for the online help.

To add or remove a column, go to View>Add/Delete Columns.  
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Scroll through the list of columns and check (click on) the boxes for all columns you want showing in the Grid View.   Uncheck (click on checked columns) those that you don’t want showing in the Grid View.  Click “OK” when you have selected the columns that you want to show.  Don’t worry – the data in the other columns is still there – it’s just “hidden” from view if that column is not selected for display.   Remember, once you have the columns you want showing, you can “drag and drop” the column headings to arrange them in the order you want.

Saving Views:

I hear you say, “I’d like some columns showing when I’m selecting caches to hunt, different columns showing when I’m printing out the grid to take with me, and still other columns showing when I log my caches at the end of a day of geocaching.  Isn’t there an easier way than adding and removing columns each time?”  The answer, of course, is “Yes!”

Once you have the columns you want showing, in the order you want them, go to View>Save Current View.  Give the view a name (e.g. “Logging” or “Printing”) and click “OK”.  Note that the names of saved views cannot contain quotation marks (“) or punctuation.  

Now when you want to switch to your “Logging” view, just go to View>Select View and choose the view you want.  Or, you can use the “Views” drop down in the GSAK toolbar.   Now that you know how to save and switch between views with just a couple of clicks of the mouse, make sure you create views that meet your needs!   By the way, you can change a saved view at any time by changing the actual view (adding, removing or rearranging columns) and then just save it again with the same name.  

Customizing the Speedbar:

Views aren’t the only thing you can customize in GSAK.  The speedbar is the area just below the menus at the top of GSAK window, with all of the buttons that allow you to do things in one click.   
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You can customize the speedbar by rearranging, adding or removing buttons.  

Let’s start by rearranging buttons.   All the buttons are over on the left side of the speedbar – GSAK looks a little “unbalanced”.   You’ll use the filter button and the cancel filter button a lot, so let’s move those over where they’re easier to find.   Right click on an empty area in the speedbar and choose “Customize Tool Buttons”.  

Now “grab” the Filter button (left click on the Filter button and hold down your mouse button) and “drag” it to the right.  Drop it anywhere in the open space on the right side of the toolbar.   Next, grab and drag the Cancel Filter button, placing it next to the Filter button on the toolbar.  Click “OK” in the customize speedbar dialog.  Voila!  Your buttons are now arranged the way YOU want them to be.

Now let’s right click on the speedbar and choose “Customize Tool Buttons” again.  In the “Customize Speed Bar” dialog window, you’ll notice there are two panes.  The left pane lists categories that are similar to the GSAK menus.  The right pane shows the buttons available for each category.  
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If you use Google maps or satellite views often, wouldn’t it be handy to have a button right on the speedbar that would show you the current cache in Google maps?   

Scroll down to the bottom of the categories in the Customize Speedbar window and click on “Custom URL’s”.   Now scroll down to the bottom of the available buttons and click on the “Google Maps” button (“GOO”).   

Hold down your mouse button, drag the “GOO” button to the Speedbar, and drop it where you want it in the Speedbar.   Click “OK” in the Customize Speedbar window.   Select a cache in the GSAK grid and click on the “GOO” button in the Speedbar – presto – a browser window pops up and shows you that cache’s location in Google maps (assuming you’re connected to the Internet).

Right click on the speedbar and choose “Customize Tool Buttons” again.  Browse through the categories to see if there are any other buttons you’d like to add to the speedbar and drag and drop them onto the speedbar.   

Too many buttons on the speedbar, or buttons you’ll never use?  Just drag and drop the button off the Speedbar.  It’s no longer cluttering up YOUR speedbar!

One more thing before we move on.  In the Customize Speedbar window, the next to the last category is “Macros”.   If you click on that category, you’ll see a series of buttons labeled “All Macros” and Macro1, Macro2, etc.  Macros are sets of instructions your can write that tell GSAK to do things in a customized way.   We won’t get into macros in this lesson, but if you do later decide to create a macro, remember that you can come here and add that macro to a button, then drag it to the Speedbar, and your customized instructions to GSAK are just one click away.

Click “OK” in the Customize Speedbar window and we’ll move on to the next topic in how you can create “My GSAK”.

Customizing the Search Bar:

The Search Bar is the area below the speedbar and just above the GSAK grid view.  
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To customize the Search Bar, right click on an empty area of the Speed Bar and choose “Customize Search Bar”.  A Customize Search Bar dialog window will open.  

[image: image5.png]Customize Search Bar [

You can drag any tem to a new positon, and any ems that have edge points can be resized

Yo can alsa resize the search bar by chagaing donn the middle edge pont on the search
bar

Selecttems that shuldbe viskle |

¥ LockFistColum ¥ Code Seaich ¥ Navigation Bar
¥ Name Sesich ¥ Spit Screen Fomat [V SavedFiters
¥ Database ¥ Losatons v Views

3
X Cancel P Help





Use this dialog to select the items you want showing on the search bar by checking or unchecking the box for each item.  Don’t use the navigation bar?  Just uncheck its box and click “OK” and it will disappear from your GSAK view.

As the dialog notes, you also can rearrange the search bar items to a new location on the bar.   Just click in the middle of a box (the white area) and drag the box to a new location. You also can resize the items (make them larger or smaller).  To resize an item, left click on the black square on the edge you want to change.  If you want to make the box taller, click the middle black square on the top of the frame and drag it upward.  To make a box wider, click on the middle black square on the right or left side of the box and drag it outward.  

Note:  When rearranging or resizing items on the search bar, be careful that the items are not overlapping.  GSAK will not check for this situation, and it is therefore possible to partially or completely obscure one item with another!  

When you’re finished rearranging the search bar, click “OK” in the Customize Search Bar dialog to save your changes.

Customizing Other GSAK Features
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There are a number of other GSAK features that you can customize, all accessible from the Tools>Options menu, or by clicking on the Tools button on the Speed Bar (shown to the left of this paragraph).  To get started, click on the Tools button and, if it’s not already showing, the “General” tab.

General Tab

Default Action When You Double Click on a Waypoint Name:  This dropdown allows you to choose from among a number of actions that GSAK can take when you double click a waypoint in the GSAK Grid View.  There are 19 different choices – different actions you can tell GSAK to take when you double click a cache!  For more information on each choice, go to Help>Contents>Configuring GSAK>Options>GSAK Options: General or Click Here for the online help.  Remember that you can click on the view of the screen (within GSAK help or within the online help) to receive more detailed information about the item shown!

Method for matching placed (hidden) and found caches:  This is the setting that tells GSAK who you are.  This setting is very important for certain features in GSAK to work correctly, including found and placed cache counts and filtering by found or placed caches.   You only have to set it up once – GSAK remembers who you are after that.

There are four ways to tell GSAK who you are.  Most GSAK users will not need Wild Card Match or RegEx and their use is beyond the scope of this guide - please see the GSAK help file for more information on those two methods.  To use either Exact match or Owner ID#, click on the circle in front of the choice and then enter the relevant information as outlined below.

The simplest method is Exact match.  If your geocaching name is “Geocacher”, you enter “Geocacher” (without the quotes) here to match your placed and found caches.  However, under some circumstances, Exact Match will not identify all of your found or placed caches, which is why “Owner ID#” is recommended for most users.  

Owner ID# is a unique number assigned to each user by geocaching.com.   Your Owner ID# does not change even if you change your geocaching name, and a cache you place always has your Owner ID#, even if you use an alias for “Who Placed the Cache?” on the geocaching.com online form to report a new cache.  Owner ID# is therefore the most reliable method for matching all of your placed and found caches.

Don’t know your Owner ID#?   You can easily locate it using one of the following approaches:

1) If you have placed (hidden) caches: Go to the geocaching.com page for a cache you own and download the GPX file for that cache.  Load the GPX file into your GSAK database.  Add the “Owner ID” column to your GSAK view (see “Adding and Removing Columns”, above).   Locate the cache you own in the GSAK Grid View and copy down the number from the “Owner ID” column.

2) If you have found caches: Go the geocaching.com page of a cache you recently found and download the GPX file for that cache.   Open the GPX file with any text editor (e.g. Notepad, Wordpad, Microsoft Word, Word Perfect).  Search (Edit>Find in most text editors) for the Geocaching.com name under which you logged the cache.  This should take you to a line that looks like this:  <groundspeak:finder id="123456">Geocacher</groundspeak:finder>.  Your Owner ID# is the number right after “groundspeak:finder id=”.

3) If you don’t own any caches and haven’t found any caches:  Log into geocaching.com and click on “Forums” in the menu on the left side of the page.  Scroll down and click “Enter the Groundspeak Forums”.   Click on the “Getting Started” forum, then click on the “Testing, Testing…Test Posting Area”.  Click on the “Add Reply” button.  Type anything in the entry box (e.g. Just testing) and then scroll down and click on the “Add Reply” button.  Hover your cursor over (don’t click) your geocaching name in the upper left corner of the post you just added.  Your OwnerID# will appear in the status bar at the bottom of your browser window, immediately after “showuser=”.  

Once you have you Owner ID#, in GSAK, go to Tools>Options General tab, click on the circle in front of “Owner ID#” and enter your number in the white box, then click on the “OK” button to close that dialog box.
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Now on to some other items on the Tools>Options General tab:

Status Attributes:  Allows you to change the colors assigned to caches that are unavailable, placed by you, found by you, or not found by you.  You can also set the priority for the colors – e.g. if a cache is both unavailable and not found by you, the color with the higher priority is the one GSAK will use.   You can also decide whether to highlight (color) the GC code or the first column (regardless of what information is in the first column).

User Sort:  The User Sort setting allows you to define how GSAK behaves when you double click on the User Sort column in the GSAK grid.  Each double click in the User Sort column for a waypoint will cause GSAK to insert a number in the user sort box for that cache.   “Current Value” is one less than the value that GSAK will enter the first time you double click on the User Sort box, and “Increment By” is the number it will add each time you click in the User Sort box.  For example, if you want GSAK to make the User Sort number for the first cache where you double click in that column “1”, and you want it to add one to each subsequent click (e.g. 2, 3, 4, 5), set the Current Value to “0” and the “Increment By” value to “1”.   

This is a very quick way to order caches for a day’s hunting (double click each cache’s user sort box in order, then click the user sort column heading to sort the caches in that order).  Note that GSAK remembers the current value and you therefore have to reset the “Current Value” each time you want to start a new ordering of caches.

The other options are the “General Tab” are self-explanatory, so we won’t cover them in detail here.  But we do recommend that you look at (and play with) the other options on this tab to get a sense of what you can do to make GSAK work for you!

HTML Tab

The Tools>Options HTML tab is where you customize settings for the GSAK HTML views (print, export or split screen).   

Custom URL’s:

Of more interest to most users, this is also where you can add “Custom URL’s”.   When you right click on a cache in the GSAK Grid View, a menu pops up that includes a “Custom URL’s” choice.  These are links to various webpages that you can activate for that cache – things like viewing the cache page at Geocaching.com, on various online mapping sites, etc.  There’s also a custom URL to log the cache at Geocaching.com (it takes you directly to the log page for that cache) and one to add the cache to your watchlist.  

All of these built in custom URL’s are listed here, if you want to see what they look like and how they work.  If there are custom URL’s you don’t use, you can delete them from the list.  You can also add custom URL’s of your own, or new ones discovered by other users (often posted in the GSAK forums), by adding a new line and following the format shown, which is: Name=URL.  Note that if you precede any custom URL with an exclamation point (!), it will appear in GSAK generated HTML.   For more information on custom URL’s, see the GSAK help file (Help>Contents>Configuring GSAK>Options>GSAK Options: HTML or the online help (Click Here).

Abbreviations Tab

Add Abbreviations: The Abbreviations Tab allows you to add geopolitical (e.g. Geocaching.com “state” names) abbreviations for your area that may not be standard in GSAK.  To add an abbreviation, just place it on a new line and follow the format shown, i.e. Full Name=Abbreviation.  Clicking on the Default flags for the US, Australia and Canada will show you the defaults for those countries.

Convert Abbreviations:  If you check the box in front of “Convert (abbreviate) state names on import”, GSAK will perform a conversion of full state names to their abbreviations (handy when you want to show the State column in the grid view but keep it narrow so it doesn’t take up too much of your screen) and from the abbreviations back to the full state names.   

To make the conversion, check the “Convert” box and then click on the appropriate button (e.g. “Full State to Abbreviation” will convert all existing and future State names to their abbreviation, as specified on this page). 

Enjoy customizing GSAK to the way you use it!  

